When something is a fresh project you’re always willing to try the latest, brightest, most shiny new software for it. Problem is that this blog is no longer that!

With 780 posts in 3 years, 110000 individual visitors in the last 12 months, 3Gb monthly data transfer, and a number of unusual Wordpress plugins this is no simple blog from a technical point of view. So it was with a bit of trepidation that I finally got around to upgrading to Wordpress 2.5.1 today, and rearranging a couple of things with the permalinks and headers of the pages. So far it looks like everything has worked out OK, and the interface changes are really smart.

All the other blogs I’ve made with Wordpress are getting upgraded to 2.5.1 as well, and thereafter I’m going to be strict with the upgrade schedule for all of them. I’ll be doing the same for all the Typo3 websites too – upgrading those to Typo3 4.2.0 and thereafter any new releases. Problem is I’ve made rather a lot of sites over the years, so it’s going to be a bit of a time-consuming process every few weeks. But better that than security breaches.

3 Comments

  1. Ben Furber

    I was a bit quick to use the latest version that for one of my sites I used 2.5! Regretted that of course and updated to 2.5.1 as soon as it was out.

  2. I am aware of it… Just never managed to get it working properly. I’m only using shared hosting packages with very restricted SSH permissions. 🙁

  3. You’re aware of Subversion?

    http://wordpress.org/download/svn/

Leave a Comment

Your email address will not be published. Required fields are marked *